- ) A variable name can't contain any spaces
- A variable name can contain only letters, numbers, dollar signs, and underscores
- I teach the camelCase naming convention. Why "camelCase"? Because there is a hump or two (or three) in the middle if the name is formed by more than one word. A camelCase name begins in lower case. If there's more than one word in the name, each subsequent word gets an initial cap, creating a hump. If you form a variable name with only one word, like response, there's no hump. It's a camel that's out of food. Please adopt the camelCase convention. It'll make your variable names more readable, and you'll be less likely to get variable names mixed up.
- Make your variable names descriptive, so it's easier to figure out what your code means when you or someone else comes back to it three weeks or a year from now. Generally, userName is better than x, and faveBreed is better than favBrd, though the shorter names are perfectly legal. You do have to balance readability with conciseness, though. bestSupportingActressInADramaOrComedy is a model of clarity, but may be too much for most of us to type or read. I'd shorten it.